Jump to content


Update 7.3


  • Please log in to reply
11 replies to this topic

RibbleStripe #1 Posted 05 October 2020 - 01:57 PM

    Sergeant

  • Administrator
  • 2311 battles
  • 260
  • [WG]
  • Member since:
    10-04-2017

In the latest version of the game, the European Nation is building up its firepower. The wild temper of Italian medium tanks will be balanced out by the Nordic durability and cold anger of Swedish heavies. This branch features five tanks with diverse armaments ranging from classic cannons to guns with autoreloaders or magazines. Check out these Swedish warriors and prepare to lead them to victory!

 

 

Full news text



RynnivaTykki #2 Posted 08 October 2020 - 09:04 AM

    Senior Sergeant

  • Player
  • 71639 battles
  • 704
  • [VIBES]
  • Member since:
    11-16-2016
Great. You broke the queue. Have now been waiting over 10 minutes to get into battle in the new Strv 42.

Had to wait over 45 mins to get a battle. What a matchmaker!

Edited by RynnivaTykki, 08 October 2020 - 09:43 AM.


Thekingoftheworldoftanks #3 Posted 08 October 2020 - 09:52 AM

    Sergeant

  • Player
  • 1464 battles
  • 454
  • [HRG]
  • Member since:
    06-28-2020
The game isn't letting me log in and the update hasnt been released on ms store yet.
Please co-operate with Microsoft the next time!!!
This happens every single update.
The update goes live before I get the option to update it.

duranciuszek #4 Posted 08 October 2020 - 10:38 AM

    Lance-corporal

  • Player
  • 42697 battles
  • 29
  • [PAT]
  • Member since:
    12-08-2014
Two hours after update (iOS), not able to join any game. Queue now is around 100-ish players.

O_o__O_o__O_o #5 Posted 08 October 2020 - 10:59 AM

    First Sergeant

  • Player
  • 48805 battles
  • 1,141
  • [AFK]
  • Member since:
    12-16-2015

nothing is broken just MM is working properly

maybe 80 of those 100 play the new tank so expect long waiting times since you cant fill whole team with same tanks



Thekingoftheworldoftanks #6 Posted 08 October 2020 - 02:27 PM

    Sergeant

  • Player
  • 1464 battles
  • 454
  • [HRG]
  • Member since:
    06-28-2020

View PostO_o__O_o__O_o, on 08 October 2020 - 10:59 AM, said:

nothing is broken just MM is working properly

maybe 80 of those 100 play the new tank so expect long waiting times since you cant fill whole team with same tanks

Well actually, you can.

I've played a game with 10 pz4d's

 



Thespiritphoenix #7 Posted 08 October 2020 - 04:08 PM

    Lance-corporal

  • Player
  • 5324 battles
  • 22
  • [_ONLY]
  • Member since:
    01-05-2019

View PostThekingoftheworldoftanks, on 08 October 2020 - 02:27 PM, said:

Well actually, you can.

I've played a game with 10 pz4d's

 

I have played a game with 12 Lago's I am actually quite proud of that particular one as it is how I mastered the Matilda



SHUTTLEBUS13 #8 Posted 08 October 2020 - 04:29 PM

    Private

  • Player
  • 33237 battles
  • 5
  • [TAPAS]
  • Member since:
    10-02-2013

On Mac I can't update, it starts for a second or two then reverts to Update icon. Ive already had to delete Icon in Launchpad as advised by WOT for a previous glitch, now I can't get in at all.

Anyone have an answer.

cheers

SB



O_o__O_o__O_o #9 Posted 08 October 2020 - 08:40 PM

    First Sergeant

  • Player
  • 48805 battles
  • 1,141
  • [AFK]
  • Member since:
    12-16-2015
i have answer dont buy mac its very simple 

Thekingoftheworldoftanks #10 Posted 09 October 2020 - 07:01 AM

    Sergeant

  • Player
  • 1464 battles
  • 454
  • [HRG]
  • Member since:
    06-28-2020
Anyone know what the new boosters are for???
Are they something to do with the upcoming mad games event?

O_o__O_o__O_o #11 Posted 09 October 2020 - 08:24 AM

    First Sergeant

  • Player
  • 48805 battles
  • 1,141
  • [AFK]
  • Member since:
    12-16-2015
probably yes just check last year lycan event should be same 

Alexike123 #12 Posted 10 October 2020 - 01:36 PM

    Private

  • Player
  • 14168 battles
  • 2
  • Member since:
    08-09-2012

 

 

Hi, 

I have encountered an issue with my Icons/Avatars disappearing after 7.3 update as well as for everyone whilst in game.

Also my profile background isn't working.

 

 






1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users